目 录CONTENT

文章目录

Pydroid3 7.2中文整合版 (汉化+内置所有依赖)安装教程

qaiu
2024-03-31 / 2 评论 / 13 点赞 / 5,838 阅读 / 1,315 字 / 正在检测是否收录...
温馨提示:
欢迎加入C4droid交流群: 1026766509(验证问题自行百度)
有什么疑问可以评论区留言,也可以加QQ736226400咨询
也可以进入问题反馈平台上传相关错误信息或者截图
提问之前建议阅读下提问的智慧
小站运营不易,还请不要屏蔽广告😘
本站内容长期更新,点击这里去打赏支持
手机支付宝用户点击这里打赏博主喝杯咖啡吧❤️❤️

声明

Pydroid7.2中文整合版基于Google play的pydroid7.2修改,解锁高级功能参考了云中龙++发布的pydroid3v7.0DIC

该版本仅供学习参考使用,禁止任何二次售卖行为(APP关于界面提供打赏入口,打赏支持,不胜感激!),如果条件允许,建议付费支持一下官方正版。
为什么要制作整合版本? 开箱即用,免去用户手动安装各类依赖的麻烦,避免了有些依赖安装失败导致的各类问题,使用jupyter仅需一行命令:jupyter notebook

教程更新日志

2024-03-31 发布7.2汉化整合版, 打包了插件提供的所有依赖, 直接安装即可,本次更新修复了pydroid3无法访问全部文件的问题。

2023-11-18 发布7.0汉化整合版, 打包了插件提供的所有依赖, 直接安装即可(为了表述方便,以后包含所有obb依赖的全量版统一称之为整合版)

2023-07-19 发布6.2.1汉化整合版, 打包了插件提供的所有依赖, 直接安装即可

2023-04-28 发布6.2汉化版, 使用云安装脚本简化安装流程; 之前的版本安装繁琐不建议使用

2023-04-22 网盘直链下载解析器重构完成, 测试应该没啥问题, 如果遇到无法下载的问题, 请及时和我联系

微信图片_20230719105021

版本说明(v7.2)

Screenshot_2024-03-31-01-04-36-467_com.miui.securitycenter-edit

  • Pydroid3v7.2汉化整合版需要安装2个Apk分别是Pydroid3v7.2中文整合版Pydroid 3_7.2_arm64_q_cn.apk、Pydroid3权限插件Pydroid Permissions Plugin_2.2_sign.apk,都是在原版基础上重新签名如果存在签名冲突,需要卸载之前版本和插件重新安装。

  • 该版本同时提供汉化版和英文版(只提供整合版),由于精力有限,仅提供aarch64架构版本,其他x86或者arm等需求可付费定制。

  • 整合版内置了预制库插件提供Whl库因此APK体积膨胀到了300+M安装后2.3G左右,如人工智能机器学习相关领域开发的TensorFlow和PyTorch,图像识别相关的OpenCV,QT组件库等等,如果只是基于Console学习Python入门可以不必安装整合版, 安装精简版即可, 体积更小。

  • 更新版去除300M大小左右的assets资源包,仅为之前安装过7.0的用户升级安装,新安装用户请勿使用。

  • 精简版仅提供基本的Python环境,不包含机器学习等高级算法库也没有Jupyter,比较适合小白。

  • 中文版其他细节修改:

    • 默认主题改为黑色,默认字体改为12号,默认关闭信息收集,默认允许键盘建议(防止出现输入法为安全键盘问题),去除订阅管理。
    • 整合版新安装后首次启动会解压资源包,耗时比较长(1-3分钟)。

视频讲解:

下载地址(仅支持aarch64架构)

Pydroid3v7.2中文整合版

Pydroid3v7.2英文整合版

Pydroid3v7.2中文更新包

Pydroid3v7.2中文精简包

Pydroid3权限插件

备用下载地址

Pydroid3v7.2中文整合版

Pydroid3v7.2英文整合版

Pydroid3v7.2中文更新包

Pydroid3v7.2中文精简包

Pydroid3权限插件

安装指南

  1. 根据需求下载安装一个中文版或者英文版和一个插件。

    • 如果之前安装过7.0整合版,请下载7.2的更新包(12MB),不必重新安装,权限插件无需升级。
    • 如果是第一次安装,根据需要选择精简版(65MB)和整合版(310MB)
  2. 初次打开Pydroid会进行Python初始安装, 因为是整合版所以安装会比较慢一般不会超过3分钟(视手机性能而定)。

常见问题

  1. 安装失败:
  • 签名冲突 卸载旧版本和插件, 插件没有图标需要在系统设置-应用管理卸载

  • 不兼容: 当前只支持aarch64架构

  1. pyzstd安装报错:终端下运行
pip install pyzstd==0.15.6
  1. pip安装某些依赖库失败: 这个问题比较普遍, Pydroid能力有限, 如果指定旧版本安装依旧报错的话也没办法.
  2. 代码运行报错或者其他疑难杂症,Google/Bing/百度/一下,或者进去QQ群(1026766509)讨论,或者留言评论,或者去问题反馈平台截图提问,由于博主精力有限加QQ视问题难度提供付费解答。
  3. 为了防止后台切换时软件重启导致丢失代码,建议关闭电量优化:MIUI-省电策略-无限制。
  4. 整合版不需要额外安装预编译库插件(Pydroid repository plugin),使用pip菜单安装库时需要取消勾选使用Prebuilt库存储库如图:
    IMG_20240331_220352
13

评论区