目 录CONTENT

文章目录

Pydroid3 v6.2.1全量版(汉化+内置所有依赖)安装教程

qaiu
2023-07-19 / 33 评论 / 23 点赞 / 14,490 阅读 / 975 字 / 正在检测是否收录...
温馨提示:
欢迎加入C4droid交流群: 1026766509(验证问题自行百度)
有什么疑问可以评论区留言,也可以加QQ736226400咨询
也可以进入问题反馈平台上传相关错误信息或者截图
提问之前建议阅读下提问的智慧
小站运营不易,还请不要屏蔽广告😘
本站内容长期更新,点击这里去打赏支持
手机支付宝用户点击这里打赏博主喝杯咖啡吧❤️❤️

教程更新日志

2023-11-18 发布7.0全量版-推荐安装, 打包了插件提供的所有依赖, 直接安装即可
2023-07-19 发布6.2.1全量版, 打包了插件提供的所有依赖, 直接安装即可
2023-04-28 发布6.2汉化版, 使用云安装脚本简化安装流程; 之前的版本安装繁琐不建议使用
2023-04-22 网盘直链下载解析器重构完成, 测试应该没啥问题, 如果遇到无法下载的问题, 请及时和我联系

微信图片_20230719105021

版本说明

  • Pydroid3 v6.2.1全量版需要安装2个Apk分别是Pydroid6.2主程序Pydroid权限插件
  • 该版本和6.2唯一区别是内置了预制库插件提供Whl库因此APK体积膨胀到了200多M,如人工智能机器学习相关领域开发的TensorFlow,图像识别相关的OpenCV,QT组件库等等,如果只是基于Console学习Python入门可以不必安装全量版, 安装6.2汉化版即可, 安装体积更小(50M)
  • Pydroid6.2汉化版基于MT默认签名可能在某些平台会报毒 当前已使用V1+V2+V3方案签名,正常不会报毒的,如有报毒请及时反馈,并提供手机型号,系统版本号等信息。
  • 如果之前已经安装过本站提供的其他版本需要卸载主程序(不含插件)重新装,如果安装过官方原版需要卸载主程序和2个插件(否则可能签名不一致安装失败)。
  • 为什么要制作全量包版本:虽然pydroid3一直在Google商店更新,但二进制2年多没啥变化了,其轮子(whl)插件内置的依赖越来越难自洽,出现了各种版本导致依赖安装失败问题,开始还能通过降低版本解决,但最近发现TensorFlow和jupyter都安装不了了,于是干脆将依赖全部打包

视频讲解:

下载地址

Pydroid6.2.1全量版主程序
Pydroid3权限插件

备用下载地址

Pydroid6.2.1全量版主程序

Pydroid3权限插件
https://lanzoui.com/izE6C0tvlsej

安装指南

注意,一定要卸载旧版本重装,不要升级!
注意,一定要卸载旧版本重装,不要升级!
注意,一定要卸载旧版本重装,不要升级!

  1. 分别下载两个Apk安装包,
  2. 安装主程序一个插件
  3. 初次打开Pydroid会进行Python初始安装, 因为是全量包所以安装会比较慢, 一般进度条到100%后等个一两分钟就会安装完毕(视手机性能而定, RedmiK40一分钟左右)

总结一下:

下载并一个主程序和一个插件安装即可

常见问题

  1. 安装失败:
  • 签名冲突 卸载旧版本和插件, 插件没有图标需要在系统设置-应用管理卸载
  • 不兼容: 当前只支持aarch64架构
  1. pyzstd安装报错:终端下运行
pip install pyzstd==0.15.6
  1. pip安装某些依赖库失败: 这个问题比较普遍, Pydroid能力有限, 如果指定旧版本安装依旧报错的话也没办法.
  2. 代码运行报错: Google/Bing/百度一下吧
  3. 部分机型默认弹出安全键盘需要设置(设置->编辑)允许键盘建议才能使用输入法:
    f66c7e905adefac380915c407f1cef2

如果其他问题,请在评论区留言,需要截图的,请加QQ或者去兔小巢(文章置顶温馨提示链接)反馈

23

评论区